[Twisted-Python] Re: [Twisted-commits] r18549 - Clean up t.web.soap.SOAPPublisher.lookupFunction
jml at mumak.net
Fri Oct 27 21:12:27 EDT 2006
On 10/28/06, Jean-Paul Calderone <exarkun at divmod.com> wrote:
> On Thu, 26 Oct 2006 23:31:32 -0600, Jonathan Lange <jml at wolfwood.twistedmatrix.com> wrote:
> > [snip]
> >+ self.assertTrue(self.publisher.lookupFunction("add"))
> >+ self.assertTrue(self.publisher.lookupFunction("fail"))
> >+ self.assertFalse(self.publisher.lookupFunction("foobar"))
> assertTrue? assertFalse? :/ Why does trial have _four_ different names
> for each of these functions?
Compatibility, both backwards and lateral.
I don't think I would object if someone decided to make the coding
standard restrict the allowable names of assert methods.
More information about the Twisted-Python