[Twisted-Python] Re: [Twisted-commits] r14397 - This appears to fix 2.2 support for me.

James Y Knight foom at fuhm.net
Sat Sep 10 01:30:04 EDT 2005

On Sep 9, 2005, at 7:55 PM, Jonathan Lange wrote:
> They didn't. Trial has always had code to test for 2.3ness before
> running doctests.

Indeed, I was mistaken. I thought that the reason doctest.py was in  
there was for compatibility with python 2.2. But it's not -- it  
contains lots of python 2.3isms. Really it was for compat with Python  
2.3. That should be documented somewhere so I don't forget again.


More information about the Twisted-Python mailing list