[Twisted-Python] Python 2.2 Support

Jonathan Lange jml at mumak.net
Tue Oct 11 00:31:30 EDT 2005

Should we drop Python 2.2 support in Subversion head for Twisted 2.2?

- Debian stable now comes with Python 2.3
- Twisted 2.1 has been released with Python 2.2 support

Dropping Python 2.2 support has some good consequences:
- We get to delete code
- An entire class of bugs gets eliminated
- Disc space can be freed on the muon buildslave

Some bad consequences:
- People wanting to run Twisted 2.2 (or svn) on ancient versions of
Python won't be able to.


More information about the Twisted-Python mailing list