[Twisted-Python] Python 2.2 Support

Daniel Henninger jadestorm at nc.rr.com
Sat Nov 5 21:10:12 EST 2005

On Nov 5, 2005, at 8:14 PM, Christopher Armstrong wrote:
> On 11/6/05, Jean-Paul Calderone <exarkun at divmod.com> wrote:
>> On Sat, 5 Nov 2005 17:00:14 +1100, Christopher Armstrong  
>> <radeex at gmail.com> wrote:
>>> On 10/11/05, Jonathan Lange <jml at mumak.net> wrote:
>>>> Should we drop Python 2.2 support in Subversion head for Twisted  
>>>> 2.2?
>>> I consider this issue resolved, given the lack of response for  
>>> people
>>> wanting 2.2 support. The buildslave for 2.2 should be taken down and
>>> Twisted trunk should be considered fair for 2.3-only features.
>> Lack of interest in a change doesn't dictate that the change be  
>> made.  I didn't hear anyone come out against the change _or_ for it.
>> If it will help, I'll throw in against dropping 2.2 support.   
>> Neither 2.3 nor 2.4 introduce any compelling new features.
> You are confused. At least two people were *for* dropping 2.2 support
> in this thread, and nobody was against it. I'm pretty sure several
> others have been for dropping it on IRC, as well.
> I have seen people several times commit code that requires 2.3,
> realize that the buildbot failed, and replace the code with a more
> complicated version (didn't you do this recently yourself, Jp?). I
> personally find it harder and harder to test 2.2, as finding an
> installation of 2.2 is getting rarer these days. To unshamedly list
> features from the "What's new in Python 2.3" article:

I can say that I do not particularly like having to support 2.2.  =)   
RedHat EL3 (which is still supported by RedHat) still has python 2.2  
though by default.  I don't know what other "still supported"  
distributions might have it.  When I forced "at least 2.3" on my  
PyAIM/PyICQ transport users, I got a fair number of complaints and a  
couple of "well then I can't use your transport".  I'm not entirely  
sure why one can't just install python 2.3 or higher if that's a  
requirement, but hey.  =)  Anyway, I'd almost be happier if Twisted  
didn't support 2.2 anymore simply because I could use that as a  
catalist for dropping support for it on my end as well.  I actually  
have to implement my own bool class to get real booleans in 2.2.. and  
that file is there only for 2.2.  =/  I can't put any real facts  
behind this, but it "seems" like unicode support isn't as good in 2.2  
either.  That might just be my imagination though.  =D


More information about the Twisted-Python mailing list