[Twisted-Python] Twisted 2.0 prerelease (close!!)

James Y Knight foom at fuhm.net
Fri Mar 11 20:52:25 EST 2005

On Mar 11, 2005, at 8:07 PM, Christopher Armstrong wrote:

> On Fri, 11 Mar 2005 19:37:50 -0500, Mike C. Fletcher
> <mcfletch at rogers.com> wrote:
>> Built fine on FreeBSD, but I wound up having a problem with the older
>> version of Zope (ZopeX3-0.0m4) whose interfaces were not compatible 
>> with
>> Twisted (crashed somewhere deep in twisted trying to manipulate
>> something in the interface module IIRC), once the old Zope was removed
>> and replaced with a later version of Zope (ZopeX3-3.0.0c1) everything
>> ran fine.
> Thanks a lot, I'll mention this in README files.

Twisted requires Zope-Interface >= 3.0.1. (it will *mostly* work with 
previous versions, but there is a subtle bug). We need to mention that. 
I don't know what version of ZopeX includes that version, but if we're 
going to tell people about Zope at all (vs Zope-Interface), we need to 
make sure to get the version right.


More information about the Twisted-Python mailing list