[Twisted-Python] SSH connection

Michal Pasternak michal at pasternak.w.lub.pl
Fri Feb 27 11:40:33 EST 2004

Schollnick, Benjamin [Fri, Feb 27, 2004 at 11:18:55AM -0500]:
> On the assumption it is PyCrypto....  I tried to install PyCrypto...

Yes, you're right. The package is called py-amkCrypto in pkgsrc, homepage at
http://www.amk.ca/python/code/crypto.html, works with py-twisted on Unix.

> 	error: Python was built with version 6 of Visual Studio, and
> extensions need to
> 	be built with the same version of the compiler, but it isn't
> installed.

... and that's right!

To build python packages you will sometimes need a C compiler. gcc for
Windows is called "mingw" or "mingw32" (mingw.sf.net), but I suggest using
Dev-C++ from Bloodshed.net (http://www.bloodshed.net/).

To "teach" distutils to use mingw, you will need some voodo:

> Is there some way around this compile issue, does anyone know of a
> precompiled
> Windows binary for the PyCrypto kit??

Propably it exists somewhere. Google! :)

More information about the Twisted-Python mailing list