[Twisted-Python] Bug in reactor.iterate()?

Sam Couter sam at couter.dropbear.id.au
Tue Apr 27 06:52:26 EDT 2004

Itamar Shtull-Trauring <itamar at itamarst.org> wrote:
> The threadpool used by the database is never initialized if you don't
> use run(). I suggest you look at twisted.test.test_enterprise and see
> how it deals with initializing and stopping the db in tests (or just use
> reactor.run() wiith reactor.crash(), though you'll still need to stop
> the threadpool manually).

Ah... I already tried run() and crash(), but my test didn't terminate.
Now I know why - the threadpool was still running.

All works now, is good. Thanks.

Suggestion: Turn this bug into a documented feature. :)
Sam "Eddie" Couter  |  mailto:sam at couter.dropbear.id.au
Debian Developer    |  mailto:eddie at debian.org
                    |  jabber:sam at teknohaus.dyndns.org
OpenPGP fingerprint:  A46B 9BB5 3148 7BEA 1F05  5BD5 8530 03AE DE89 C75C
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
Url : http://twistedmatrix.com/pipermail/twisted-python/attachments/20040427/30661303/attachment.pgp 

More information about the Twisted-Python mailing list