[Twisted-Python] twisted and python 2.1.3

Itamar Shtull-Trauring itamar at itamarst.org
Tue Sep 23 12:30:06 EDT 2003

On Mon, 22 Sep 2003 11:13:09 -0400
Erik A.Dahl <edahl at mindspring.com> wrote:

> I'm using twisted and some other python libraries (zope) and would
> like to use them together.  Of course zope is still back in the 2.1.3
> days of python.  If I were to deal with defining True and False where
> needed would there be other compatibility issues with 2.1.3 and
> twisted?

Yes, we are using other 2.2 features as well. So, either :

1. switch to older version of Twisted (1.0.4 had 2.1 support).
2. upgrade Zope to use 2.2 (current versions while not officially
supported do run decently on 2.2 - ask around).
3. Wait for Zope 2.7 which runs on python 2.2 IIRC. 
4. Run Twisted and Zope in different processes and communicate via
XML-RPC or something like that.

Personally I'd try for #4 in most cases.

Itamar Shtull-Trauring    http://itamarst.org/
Available for Python & Twisted consulting

More information about the Twisted-Python mailing list