[Twisted-Python] Perspective Broker in 1.0.7

Itamar Shtull-Trauring itamar at itamarst.org
Tue Sep 16 14:25:06 EDT 2003

If you are using PB code, you will start getting deprecation warnings
when you upgrade to 1.0.7. This is due to switching to:

1. A new connection API that doesn't suck.
2. New cred support.

#1 is documented in the 1.0.7 Howtos. #2 isn't.

You can however see examples of how to do #2 in CVS, specifically these
two files:


and compare them to doc/examples/pbecho(client).py in 1.0.7 or older CVS

Some of Twisted's internal code doesn't use this new API either. By 1.1
all docs, examples and code in Twisted will have switched to the new
API. The old API will of course continue to be supported for some time,
but it is recommended you switch as the new API is much cleaner and
better designed.

Itamar Shtull-Trauring    http://itamarst.org/
Available for Python & Twisted consulting

More information about the Twisted-Python mailing list