[Twisted-Python] Re: [Twisted-commits] Add makeblocking (and a test woo)

Bob Ippolito bob at redivi.com
Wed May 7 10:57:02 EDT 2003

On Wednesday, May 7, 2003, at 01:22 America/New_York, Glyph Lefkowitz 

> Hash: SHA1
> On Tuesday, May 6, 2003, at 08:57 PM, Andrew Bennetts wrote:
>> Perhaps "waitForDeferred" would be a better name for this?
> I was thinking Deferred.block(), since it would be most often used 
> like:
> 	w.x.y().block().z()
> This would probably be _super_ useful with Stackless, if we had more 
> support for it.

Yeah, without stackless, I don't think this is possible unless we put a 
macro preprocessor into python.. since you can't putz around with frame 
objects from pure Python.

Until then, you can get around with the likes of the 
generator/deferredwrapper crutch..


More information about the Twisted-Python mailing list