[Twisted-Python] Problems installing Quotient

Justin Johnson justinjohnson at fastmail.fm
Thu Aug 14 09:18:34 EDT 2003

I'm running RedHat 9, Python 2.2.2, Twisted-1.0.7alpha2, latest Quotient,
Lupy, and Reverend.

After installing Quotient, Lupy, and Reverend, I get the following error
trying to run mktap.  Do I need to be running from CVS or something?  The
instructions said 1.0.7alpha1 or greater was okay.  IMessage is not
defined in twisted.protocols.imap4.py.

[jjohn53 at marmot jjohn53]$ mktap quotient --help
An error unexpected occurred:
Traceback (most recent call last):
  File "/usr/lib/python2.2/site-packages/twisted/scripts/mktap.py", line
  182, in run
  File "/usr/lib/python2.2/site-packages/twisted/python/usage.py", line
  210, in parseOptions
  File "/usr/lib/python2.2/site-packages/twisted/scripts/mktap.py", line
  166, in postOptions
  File "/usr/lib/python2.2/site-packages/twisted/python/usage.py", line
  199, in parseOptions
    self.subOptions = parser()
  File "/usr/lib/python2.2/site-packages/twisted/scripts/mktap.py", line
  107, in <lambda>
    [x, None, (lambda obj = y: obj.load().Options()), getattr(y,
    'description', '')]
  File "/usr/lib/python2.2/site-packages/twisted/python/plugin.py", line
  68, in load
    return namedModule(self.module)
  File "/usr/lib/python2.2/site-packages/twisted/python/reflect.py", line
  369, in namedModule
    topLevel = __import__(name)
  File "/usr/lib/python2.2/site-packages/quotient/tap.py", line 15, in ?
    from quotient import login, grabbers, smtpin
  File "/usr/lib/python2.2/site-packages/quotient/login.py", line 41, in
    from quotient.imapbox import Account as IMAP4Account
  File "/usr/lib/python2.2/site-packages/quotient/imapbox.py", line 13,
  in ?
    from twisted.protocols.imap4 import IAccount, IMailbox, IMessage,
    IMAP4Server, statusRequestHelper
ImportError: cannot import name IMessage
[jjohn53 at marmot jjohn53]$

More information about the Twisted-Python mailing list