[Twisted-Python] Re: [Twisted-commits] Deprecating __getattr__, encourage people to use .callMethod

Moshe Zadka twisted at moshez.org
Tue Dec 24 10:38:22 EST 2002

On Tue, 24 Dec 2002, Glyph Lefkowitz <glyph at twistedmatrix.com> wrote:

> I'm just curious why this method was called "callMethod" rather than
> "callRemote", as with PB?  Is there some difference in semantics I'm not
> getting?

Probably not.
I renamed it to callRemote. This means that some places which were expecting
a PB object can now get an XML-RPC proxy object, which is inherently cool
(naturally there are some limitations)

More information about the Twisted-Python mailing list